Mining, Wallet guide for APPLE OS users - (PART 1)

Feel free to check out our Forums by clicking the link at the top menu of the site, we have over 10,000 Active members in the community and growing every single day! We also have the most FEATURE RICH live chat room we call "The Trollbox" where you can jump right in and talk with other Cryptocurrency enthusiasts who are also online.


  • Hey, Like this blog post if you have a Mac or know someone who has a mac and wants more support or has questions!

    I will be (hopefully) releasing a video on how to open a wallet on a Mac, how to mine + other videos coming in the future, so follow me to be updated :)


    AS PROMISED! HERE IS THE SIMPLE GUIDE TO DOWNLOAD YOUR BURST WALLET ON YOUR MAC OS X! Please show me your appreciation by donating or by leaving a like on the Youtube video!


    VIDEO STEP-BY-STEP GUIDE ON YOUTUBE: https://youtu.be/L-rgOLptq7k



    1. Download Java SE Development Kit 8u121 (JDK)  & RUN, Install it.
    DIRECT LINK:
    http://download.oracle.com/otn-pub/java/jdk/8u121-b13/e9e7ea248e2c4826b92b3f075a80e441/jdk-8u121-macosx-x64.dmg


    2. Download & RUN, Install it.

    burstcoin-1.2.8 (newest version)




    3. You have to open the folder and within that folder you must open the "run.sh" file, HOWEVER TO DO THIS BEFORE: YOU MUST TYPE THIS IN YOUR COMMAND PROMPT TERMINAL:


    a).Type :

    cd Downloads

    and press enter.


    b).Type:

    cd burstcoin-1.2.8

    and press enter.


    c). now you can run the java command which will start the server node program:

    java -cp burst.jar:conf nxt.Nxt


    4. You have to go to your burstcoin-1.2.8 folder and double-click on "Burst_Wallet.url", Open it in Google Chrome (preferably).


    This will open a local file within that folder and you will see "http://localhost:8125/index.html" on the top address.

    You will see a window like this:Screen Shot 2017-04-01 at 2.28.20 PM.png


    Enter your Passphrase, once entered a downloading window will appear:

    Downloading blockchain.png


    Once finished, you will see your fully downloaded blockchain:

    burst_db 2017-02-11 18-29-13.png


    If you encounter the following issue while downloading the blockchain,

    please visit this blog post:
    How to get the macOS / OS X - 1.2.7 Burst Wallet Up and Running
    All credits goes to @TrickyHunter



    Donate & show your appreciation | comment below if you mine with an Apple!

    GifApple-Logo.gif




    Share the Burst love:thumbup:

    BURST-QU7F-CUGH-25QB-DSFAG


    All Tips are greatly appreciated!! :thumbup:

    Want to tip but don't have the BURST??

    Just claim the faucet with my address!!

    Edited 5 times, last by simon ().

  • I have found these links here:


    However I need confirmation that they work?

    Download:


    burstcoin-jminer-0.4.9-SNAPSHOT


    https://github.com/de-luxe/burstcoin-jminer/releases

    Setup: jminer.properties


    https://github.com/de-luxe/bur…nfigure-jminer.properties

    Info/Support:


    https://bitcointalk.org/index.php?topic=1170987

    BurstcoinForum recovery:


    https://github.com/de-luxe/burstcoin-jminer/wiki/burstforum.com-thread-recovery



    another link:
    https://github.com/mrpsion/burst-mining-system

    Share the Burst love:thumbup:

    BURST-QU7F-CUGH-25QB-DSFAG


    All Tips are greatly appreciated!! :thumbup:

    Want to tip but don't have the BURST??

    Just claim the faucet with my address!!

  • Hello, I need a little assistance. I have about %75 of the blockchain for local wallet for mining on my OSx and Got this error in terminal:


    Exception in thread "main" java.lang.ExceptionInInitializerError

    at nxt.Nxt$Init.<clinit>(Nxt.java:193)

    at nxt.Nxt.init(Nxt.java:170)

    at nxt.Nxt.main(Nxt.java:161)

    Caused by: java.lang.RuntimeException: org.h2.jdbc.JdbcSQLException: General error: "java.lang.NullPointerException" [50000-193]

    at nxt.db.Db.<clinit>(Db.java:101)

    ... 3 more



    "Exception in thread "Thread-1" java.lang.NoClassDefFoundError: Could not initialize class nxt.db.Db

    at nxt.Nxt.shutdown(Nxt.java:179)

    at nxt.Nxt$1.run(Nxt.java:158)

    at java.lang.Thread.run(Thread.java:745)"


    I have moved the nxt file to the burst_db folder and the blockchain download started over. Which sucks because it takes a while.

  • Hey Team,


    First time burster and after sponging as much knowledge I took the dive today after finding an old 5TB External I had laying around.


    Now I have a Mac (Mid 2012) with an intel 2.5 i7, 8GB Ram, 256 SSD + 5TB External.

    Followed the doco above and successfully installed the wallet:


    BURST-7JVL-8CZW-HR4D-4BLCU


    and blockchain downloaded successfully.


    Downloaded and installed jminer without issues BUT when I went to try and plot my 5TB drive I get the following error:


    ./plot -k [myPublicKey] -x 2 -d /Volumes/Burst5TB_0/

    Using AVX2 core. (NOTE: I have tried 0, 1 & 2 with same error)

    Floating point exception: 8


    I am going through mine.c at the moment and am stumped.


    Has anyone else come across this error?

    Any help would be amazing.


    Thank You in advance


    Regards

    Joseph

  • Hi there,


    i tried the command to plot with jminer, i don't have error but i have no feedback on when it will finish, after a while i have this message:

    Code
    1. Using original algorithm (no SSE4, no AVX2).
    2. Adjusting total nonces to 771751936 to match stagger size
    3. Creating plots for nonces 0 to 771751936 (202453 GB) using 8388608 MB memory and 2 threads
    4. Killed: 9


    So the last message is : Killed 9


    How to know if the ploting is successful ?


    Thank you